如何安装多版本PHP环境

    护卫神·主机大师发布,如果您服务器系统是Windows 2008/2012/2016/2019等,那么推荐直接部署主机大师(Linux也有相应版本),参见 https://www.hws.com/soft/hostmaster/ 

    从主机大师V4.0版本开始,支持应用市场,支持在线选择和安装PHP,支持多个不同的PHP,如下图:

Snap2.jpg


    护卫神·主机管理系统从V3.5在Windows 2008/2012下开始支持多版本PHP,可以为每个网站使用不同的PHP版本。

    本文采用护卫神·PHP套件实现多个PHP支持,简易、快捷,还会自动配置好安全,非常适合服务器使用。


    1、下载PHP套件

        PHP5.2:http://d.hws.com/free/PhpwebFcgi52.zip (只能FastCGI模式)

        PHP5.3:http://d.hws.com/free/PhpwebFcgi53.zip

        PHP5.4:http://d.hws.com/free/PhpwebFcgi54.zip

        PHP5.5:http://d.hws.com/free/PhpwebFcgi55.zip

        PHP5.6:http://d.hws.com/free/PhpwebFcgi56.zip

        PHP7.0:http://d.hws.com/free/PhpwebFcgi70.zip



    2、安装PHP套件

        分别安装到不同的目录,注意只选择PHP模块:

PHP7.0.1套件安装


    3、加载PHP

        安装完成后,到主机管理系统后台,“系统设置”->“PHP设置”,点“自动加载”按钮,系统就会自动识别所有安装的PHP。

自动加载多个PHP

 

        这样开设主机时,就可以选择多版本PHP了。

开设虚拟主机选择PHP


    注意,Windows Server 2003 暂不支持自动配置多版本PHP,如果需要,可以由我们提供手动多PHP版本配置服务。

 

    如果您不想自己安装,可购买我司“网站环境搭建”服务,由我们帮您安装配置。


    如果您的操作系统是Linux,那么也可以安装主机大师Linux版本,配置多个PHP版本支持环境,详情请点击:https://www.hws.com/soft/hostmaster/ 

用户留言